summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-18 23:30:38 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-18 23:30:38 (GMT)
commitd2e92fd23610c3ccdddbbc55484e54a5a21a9252 (patch)
tree462898f15d85477e218439ce4719dc42beb19c5e /examples/Makefile.am
parentcd5ca85fb7c98154224628d7ef21e179bf653ff5 (diff)
downloadhdf5-d2e92fd23610c3ccdddbbc55484e54a5a21a9252.zip
hdf5-d2e92fd23610c3ccdddbbc55484e54a5a21a9252.tar.gz
hdf5-d2e92fd23610c3ccdddbbc55484e54a5a21a9252.tar.bz2
[svn-r11083] Purpose:
Bug fixes Description: A number of minor changes to Makefiles. Some files will now be cleaned properly, some comments are more informative, etc. Platforms tested: heping, mir, modi4
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 07f659b..1e4b883 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -22,8 +22,6 @@ include $(top_srcdir)/config/commence.am
if BUILD_PARALLEL_CONDITIONAL
TEST_PROG_PARA = ph5example
-else
- TEST_PROG_PARA =
endif
# Example programs.
@@ -47,7 +45,8 @@ INSTALL_FILES = h5_write.c h5_read.c h5_extend_write.c h5_chunk_read.c \
h5_reference.c h5_drivers.c ph5example.c
# We need to tell automake what to clean
-CLEANFILES=*.h5 *.raw *.meta *.clog $(TEST_PROG) ph5example *.o
+MOSTLYCLEANFILES+=*.h5 *.raw *.meta *.clog *.o
+CLEANFILES=$(TEST_PROG) $(TEST_PROG_PARA)
# Additional dependencies for each program are listed below.
$(EXTRA_PROG): $(LIBHDF5)
@@ -86,7 +85,7 @@ install-examples: $(EXAMPLEDIR) $(INSTALL_FILES)
uninstall-examples:
@if test -n "$(INSTALL_FILES)" -a -d $(EXAMPLEDIR); then \
- set -x; cd $(EXAMPLEDIR) && $(RM) $(INSTALL_FILES).c; \
+ set -x; cd $(EXAMPLEDIR) && $(RM) $(INSTALL_FILES); \
fi
check-install: