summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-11 17:40:52 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-11 17:40:52 (GMT)
commit3f0a35a4eab869793f5b3882da35a2fe0b683dbd (patch)
tree35c5a256e137aa8e16c120b4a59feab2cbeb2fe0 /examples/Makefile.am
parent54f376edbb1bce24bff19fb6b7c3d298470356be (diff)
downloadhdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.zip
hdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.tar.gz
hdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.tar.bz2
[svn-r9988] Purpose:
Bug fix Description: pmake (on modi4, for instance) complains about undefined variables if it is run without the -V flag, which turns those errors to warnings. Solution: Added test to configure.in to see if $MAKE will allow Makefiles with undefined variables. If not, sets -V flag in AM_MAKEFLAGS. Ensured that all custom make targets use AM_MAKEFLAGS. Also defined all variables that caused errors in top-level Makefile.am. This means that pmake can be used to build hdf5 *from the top level only*. To run make from a subdirectory, still need to use -V flag (or use make or gmake). Platforms tested: modi4, heping, copper, sleipnir
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index be9d5ae..222799c 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -67,9 +67,9 @@ $(EXAMPLEDIR):
-$(top_srcdir)/bin/mkdirs $@
install-data-local:
- $(MAKE) install-examples
+ $(MAKE) $(AM_MAKEFLAGS) install-examples
uninstall-local:
- $(MAKE) uninstall-examples
+ $(MAKE) $(AM_MAKEFLAGS) uninstall-examples
# We want to install the source files, not the examples themselves. Add '.c' to
# each example to get its source. This is a bit kludgy.
@@ -86,9 +86,9 @@ uninstall-examples:
fi
check-install:
- $(MAKE) installcheck
+ $(MAKE) $(AM_MAKEFLAGS) installcheck
installcheck-local:
- $(MAKE) check
+ $(MAKE) $(AM_MAKEFLAGS) check
# List dependencies for each program. Normally, automake would take
# care of this for us, but if we tell automake about the programs it