summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-08-02 17:59:03 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-08-02 17:59:03 (GMT)
commite75a185ecaab4f55afaae0855a40770a300a2cc0 (patch)
treeaa938d97ec85dea32adfad0005fbaac5ef9edb6f /examples/Makefile.am
parent7def00050fd07e93bee65e2e8ad2fac0001cc05e (diff)
downloadhdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.zip
hdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.tar.gz
hdf5-e75a185ecaab4f55afaae0855a40770a300a2cc0.tar.bz2
[svn-r11185] Purpose:
Makefile feature Description: 'make check-clean' now cleans *.h5 files created by tests as well as .log and .chkexe files. Solution: check-clean is now a separate target in its own right, which cleans less than mostlyclean (check-clean < mostlyclean < clean < distclean). Platforms tested: mir, heping, modi4 (serial and parallel)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 31e1d7a..e23603d 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -45,7 +45,8 @@ INSTALL_FILES = h5_write.c h5_read.c h5_extend_write.c h5_chunk_read.c \
h5_reference.c h5_drivers.c ph5example.c
# We need to tell automake what to clean
-MOSTLYCLEANFILES+=*.h5 *.raw *.meta *.clog *.o
+MOSTLYCLEANFILES=*.raw *.meta *.clog *.o
+CHECK_CLEANFILES+=*.h5
CLEANFILES=$(TEST_PROG) $(TEST_PROG_PARA)
# Additional dependencies for each program are listed below.