summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2013-03-26 14:52:05 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2013-03-26 14:52:05 (GMT)
commit41cd6b928b76ba8c3c39027f3de2085544f44464 (patch)
treec969d3d1b096a8ea63431d546832badd88162b41 /examples/Makefile.am
parent72553ef57e289352f7552a68704e97e684d56f1e (diff)
downloadhdf5-41cd6b928b76ba8c3c39027f3de2085544f44464.zip
hdf5-41cd6b928b76ba8c3c39027f3de2085544f44464.tar.gz
hdf5-41cd6b928b76ba8c3c39027f3de2085544f44464.tar.bz2
[svn-r23457] add --enable-eff to configure that defaults to no
add HAVE_EFF build flag to indicate whether the IOD plugin should be compiled or not add an AM conditional to indicate whether the EFF test exampels should be compiled or not tested on jam
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 245772f..c22e717 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -23,8 +23,14 @@ include $(top_srcdir)/config/commence.am
if BUILD_PARALLEL_CONDITIONAL
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test
+ LDADD = $(LIBH5TEST) $(LIBHDF5)
+ EXAMPLE_PROG_PARA = ph5example
+endif
+
+if BUILD_EFF_CONDITIONAL
+ INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/test
LDADD = $(LIBH5TEST) $(LIBHDF5) $(MYAXE_LIBS) $(MYIOD_LIBS) $(MYSHIPPER_LIBS)
- EXAMPLE_PROG_PARA = ph5example test_server test_client
+ EXAMPLE_PROG_EFF = test_server test_client
endif
# Example programs.
@@ -61,6 +67,7 @@ $(EXTRA_PROG): $(H5CC)
$(H5CC) $(H5CCFLAGS) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif
+
# Some examples depend on files created by other examples.
h5_read.chkexe_: h5_write.chkexe_
h5_chunk_read.chkexe_: h5_extend_write.chkexe_