summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorDana Robinson <derobins@hdfgroup.org>2019-02-22 19:08:12 (GMT)
committerDana Robinson <derobins@hdfgroup.org>2019-02-22 19:08:12 (GMT)
commite4b71d49a12d384e89931a620428e950dd98e4e8 (patch)
tree94798cf8cb723798fc7fda00a281b712ccdfb427 /examples/Makefile.am
parent3964f612eba8872d6fc8778f2523fd4bce47f649 (diff)
parent0e402e436d0c58acc72e45ab6153d5662b3148e0 (diff)
downloadhdf5-e4b71d49a12d384e89931a620428e950dd98e4e8.zip
hdf5-e4b71d49a12d384e89931a620428e950dd98e4e8.tar.gz
hdf5-e4b71d49a12d384e89931a620428e950dd98e4e8.tar.bz2
Merge pull request #1574 in HDFFV/hdf5 from ~DEROBINS/hdf5_der:hdf5_rados to hdf5_rados
* commit '0e402e436d0c58acc72e45ab6153d5662b3148e0': Updated the tests to use mobject. Added a RADOS/mobject #ifdef switch. Moved the rados_stat() modifications into a helper function. Finished implementation of RADOS wrappers for calls not implemented in mobject. * Added a rados_read() wrapper function (still uses rados_read()). * Some cleanup in the write wrapper. rados_write_full calls now use write_ops. Added a helper function to wrap rados_write_full(). Both rados_stats calls are wrapped. You can #define OLD_RADOS_CALLS to enable the old way of doing things. Converted one of the stats calls to use a read op instead. * Added a script to run the RADOS examples in order. * Updated BRANCH.txt with useful information about building and testing. * Makefile.am now installs everything you need as well as the test script.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 323541f..7e56f86 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -63,7 +63,8 @@ INSTALL_FILES = h5_write.c h5_read.c h5_extend_write.c h5_chunk_read.c \
h5rados_file_create.c h5rados_file_open.c h5rados_group_create.c \
h5rados_group_open.c h5rados_dset_create.c \
h5rados_dset_open.c h5rados_dset_write.c h5rados_dset_read.c \
- h5rados_dset_wpartial.c h5rados_dset_rpartial.c
+ h5rados_dset_wpartial.c h5rados_dset_rpartial.c \
+ h5rados_example.h run_rados_examples.sh run_mobject_examples.sh