summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2007-01-26 15:00:09 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2007-01-26 15:00:09 (GMT)
commit3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544 (patch)
tree49c0de341039f917e0bb82799a778ab3ad7ad4dc /examples/Makefile.am
parentfd63747fd649c609abcbcd6c6143cbe564092867 (diff)
downloadhdf5-3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544.zip
hdf5-3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544.tar.gz
hdf5-3fdcb8b3d9bb69243903b4d2ae4a67cdc5bdd544.tar.bz2
[svn-r13203] Unable to replicate Daily Test error, but hopefully this is a fix anyway.
The examples had been depending on the build libraries in src, but should have been depending only on the installed h5cc. Fixed this. Tested on kagiso (dependency change only, and was unable to replicate the problem on any system). Real test will be Daily Tests tonight.
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index b6f4b8d..1981072 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -39,11 +39,12 @@ INSTALL_FILES = h5_write.c h5_read.c h5_extend_write.c h5_chunk_read.c \
h5_reference.c h5_drivers.c h5_extlink.c h5_elink_unix2win.c \
h5_ref2reg.c h5_shared_mesg.c ph5example.c
-# Additional dependencies for each program are listed below.
-$(EXTRA_PROG): $(LIBHDF5)
+# How to build examples, using installed version of h5cc
if BUILD_PARALLEL_CONDITIONAL
+$(EXTRA_PROG): $(H5CC_PP)
$(H5CC_PP) $(CFLAGS) -o $@ $(srcdir)/$@.c;
else
+$(EXTRA_PROG): $(H5CC)
$(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif