summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2006-08-22 16:22:43 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2006-08-22 16:22:43 (GMT)
commit9d4229713ebb1ed899c5c5fa72dbaeb5611e923e (patch)
tree381374eb5ffa7cf95f6794a0910e1cdd12cf0175 /examples/Makefile.am
parentc17ea4461717a8065cc421980f897fa30a07f8d0 (diff)
downloadhdf5-9d4229713ebb1ed899c5c5fa72dbaeb5611e923e.zip
hdf5-9d4229713ebb1ed899c5c5fa72dbaeb5611e923e.tar.gz
hdf5-9d4229713ebb1ed899c5c5fa72dbaeb5611e923e.tar.bz2
[svn-r12608] Checked in External Link C examples.
Since these examples need to follow filesystem paths, the Makefiles need to create directories in the examples directory; added this to the Makefile.am. Tested on Windows, mir, juniper
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am18
1 files changed, 16 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index e6991d9..701dd70 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -29,13 +29,15 @@ endif
# it would try to compile them instead of using the h5cc script.
# Use the boilerplate in config/examples.am instead.
TEST_PROG = h5_write h5_read h5_extend_write h5_chunk_read h5_compound \
- h5_group h5_select h5_attribute h5_mount h5_reference h5_drivers
+ h5_group h5_select h5_attribute h5_mount h5_reference h5_drivers \
+ h5_extlink h5_elink_unix2win
# Install files
# List all file that should be installed in examples directory
INSTALL_FILES = h5_write.c h5_read.c h5_extend_write.c h5_chunk_read.c \
h5_compound.c h5_group.c h5_select.c h5_attribute.c h5_mount.c \
- h5_reference.c h5_drivers.c ph5example.c
+ h5_reference.c h5_drivers.c h5_extlink.c h5_elink_unix2win.c \
+ ph5example.c
# Additional dependencies for each program are listed below.
$(EXTRA_PROG): $(LIBHDF5)
@@ -49,6 +51,16 @@ endif
h5_read.chkexe_: h5_write.chkexe_
h5_chunk_read.chkexe_: h5_extend_write.chkexe_
+# The external link examples demonstrate how to use paths; they need
+# directories to be created to do this.
+EXTLINK_DIRS=red blue u2w
+
+$(EXTLINK_DIRS):
+ echo $(mkdir_p) $@
+ $(mkdir_p) $@
+
+CHECK_CLEANFILES+=$(EXTLINK_DIRS)
+
# Example directory
EXAMPLEDIR=$(docdir)/hdf5/examples/c
@@ -71,6 +83,8 @@ h5_reference: $(srcdir)/h5_reference.c
h5_drivers: $(srcdir)/h5_drivers.c
ph5example: $(srcdir)/ph5example.c
h5_dtransform: $(srcdir)/h5_dtransform.c
+h5_extlink: $(srcdir)/h5_extlink.c $(EXTLINK_DIRS)
+h5_elink_unix2win: $(srcdir)/h5_elink_unix2win.c $(EXTLINK_DIRS)
include $(top_srcdir)/config/examples.am
include $(top_srcdir)/config/conclude.am