summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorMike McGreevy <mamcgree@hdfgroup.org>2008-10-24 17:19:34 (GMT)
committerMike McGreevy <mamcgree@hdfgroup.org>2008-10-24 17:19:34 (GMT)
commita66427462495807c39be4eb48d7015253b9e8853 (patch)
tree917da048f0d071652d31232d4ede3a82c01df7af /examples/Makefile.am
parent220c8585e1af4bcff9595ff1506ad90b8c4a4736 (diff)
downloadhdf5-a66427462495807c39be4eb48d7015253b9e8853.zip
hdf5-a66427462495807c39be4eb48d7015253b9e8853.tar.gz
hdf5-a66427462495807c39be4eb48d7015253b9e8853.tar.bz2
[svn-r15942] Purpose: Bug Fixes and Libtool Upgrade
Description: - Remove need to set LD_LIBRARY_PATH when using shared szip library. - Libtool 2.2.6a is now used to generate libraries. - 'make check install' dependency bug is fixed, and should no longer break the build. - removed hard coding of shell in config/commence.am, as this causes problems on Solaris with the new version of libtool. - RELEASE.txt with appropriate changes. Tested: - kagiso, smirom, linew (merged from 1.8, pretty quick tests)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index c81213b..d3fe9c9 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -91,5 +91,9 @@ h5_extlink: $(srcdir)/h5_extlink.c $(EXTLINK_DIRS)
h5_elink_unix2win: $(srcdir)/h5_elink_unix2win.c $(EXTLINK_DIRS)
h5_shared_mesg: $(srcdir)/h5_shared_mesg.c
+if BUILD_SZIP_CONDITIONAL
+export LD_LIBRARY_PATH=$(LL_PATH)
+endif
+
include $(top_srcdir)/config/examples.am
include $(top_srcdir)/config/conclude.am