summaryrefslogtreecommitdiffstats
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-07-04 21:25:07 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-07-04 21:25:07 (GMT)
commitc80b03cf3310823e6343f24836227e3d91a5fa53 (patch)
tree7fcd65b42144354609720f8ad91cdaad9fec4e8e /examples/Makefile.am
parentddf9e4a4afc81c4be4ce38a13641ada81204b6ac (diff)
downloadhdf5-c80b03cf3310823e6343f24836227e3d91a5fa53.zip
hdf5-c80b03cf3310823e6343f24836227e3d91a5fa53.tar.gz
hdf5-c80b03cf3310823e6343f24836227e3d91a5fa53.tar.bz2
[svn-r11016] Purpose:
Bug fix Description: Added dependencies to examples Makefiles so that examples can be run in parallel. Solution: The examples directories (for C, C++, and Fortran) all have some dependencies explicitly spelled out in their Makefiles.am. This is a good short-term solution, and should prevent errors in the Daily Tests. Platforms tested: mir, modi4 (parallel and sequential)
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 222799c..07f659b 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -57,6 +57,10 @@ else
$(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif
+# Two of the examples depend on files created by other examples.
+h5_read.chkexe_: h5_write.chkexe_
+h5_chunk_read.chkexe_: h5_extend_write.chkexe_
+
# How to install examples
# There are a lot of rules because automake does not know about
# the examples programs, and does not recognize the install-examples