summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-11-01 17:29:53 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-11-01 17:29:53 (GMT)
commit930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea (patch)
tree3a3f4330b3cf840f2ce47249607d25ca3935d8cb /fortran/CMakeLists.txt
parent765d96456298aa678c072df9debba7d4be6ffb95 (diff)
downloadhdf5-930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea.zip
hdf5-930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea.tar.gz
hdf5-930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea.tar.bz2
Convert to use MPI:: for link
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index f7179cf..9f7144d 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -2,8 +2,7 @@ cmake_minimum_required (VERSION 3.2.2)
PROJECT (HDF5_F90 C CXX Fortran)
if (H5_HAVE_PARALLEL)
- INCLUDE (FindMPI)
- set (LINK_LIBS ${LINK_LIBS} ${MPI_Fortran_LIBRARIES})
+ set (LINK_LIBS ${LINK_LIBS} MPI::MPI_Fortran)
if (MPI_Fortran_LINK_FLAGS)
set (CMAKE_EXE_LINKER_FLAGS "${MPI_Fortran_LINK_FLAGS} ${CMAKE_EXE_LINKER_FLAGS}")
endif ()