summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-15 17:38:06 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2020-01-15 17:38:06 (GMT)
commita0ae5e9b896d9548a58b830f5ffad618313a854e (patch)
treea24c611d2023712db08c09cba013829c97a38f1a /fortran/CMakeLists.txt
parent4077d99645623929cf0c61779c98539efb6742e7 (diff)
downloadhdf5-a0ae5e9b896d9548a58b830f5ffad618313a854e.zip
hdf5-a0ae5e9b896d9548a58b830f5ffad618313a854e.tar.gz
hdf5-a0ae5e9b896d9548a58b830f5ffad618313a854e.tar.bz2
HDFFV-11001 Add fine control over testing
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index 31edad2..9755963 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -23,8 +23,11 @@ endif ()
# Testing
#-----------------------------------------------------------------------------
if (BUILD_TESTING)
- add_subdirectory (test)
- if (MPI_Fortran_FOUND)
- add_subdirectory (testpar)
+ if (HDF5_TEST_SERIAL)
+ add_subdirectory (test)
+ endif ()
+ if (MPI_Fortran_FOUND AND HDF5_TEST_PARALLEL)
+ add_subdirectory (testpar)
+ endif ()
endif ()
endif ()