summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-08-31 20:20:12 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-08-31 20:20:12 (GMT)
commitc9cf76d5f9abff08e2488b79825551e99adecf42 (patch)
tree378c8c9f261dd362fe07aac3329eefab3122be72 /fortran/CMakeLists.txt
parent0792a4dd4c5dc399ed4a99c799e999d9e944b5ba (diff)
downloadhdf5-c9cf76d5f9abff08e2488b79825551e99adecf42.zip
hdf5-c9cf76d5f9abff08e2488b79825551e99adecf42.tar.gz
hdf5-c9cf76d5f9abff08e2488b79825551e99adecf42.tar.bz2
[svn-r19326] Added parallel build commands.
Corrected use/name of source folder aliases. Duplicated FindMPI.cmake so that non-c++ compiler is found first (recommemded commands did not work). Bring r19325 from trunk Tested: local linux with mpich
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index 02cd07f..a4bfb17 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -149,4 +149,7 @@ ENDIF (HDF5_BUILD_EXAMPLES)
#-----------------------------------------------------------------------------
IF (BUILD_TESTING)
ADD_SUBDIRECTORY (${HDF5_F90_SOURCE_DIR}/test ${HDF5_F90_BINARY_DIR}/test)
+ IF (H5_HAVE_PARALLEL)
+ ADD_SUBDIRECTORY (${HDF5_F90_SOURCE_DIR}/testpar ${HDF5_F90_BINARY_DIR}/testpar)
+ ENDIF (H5_HAVE_PARALLEL)
ENDIF (BUILD_TESTING)