summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2011-11-03 21:06:37 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2011-11-03 21:06:37 (GMT)
commit49fabfad86090e104a2bf9273f9b93ecd8dd8e22 (patch)
tree6f033eb795b4812019e9bd0aff39c9fcf05e6140 /fortran/CMakeLists.txt
parent677380aa5a1ca7780855935422ee7a5f62682b53 (diff)
downloadhdf5-49fabfad86090e104a2bf9273f9b93ecd8dd8e22.zip
hdf5-49fabfad86090e104a2bf9273f9b93ecd8dd8e22.tar.gz
hdf5-49fabfad86090e104a2bf9273f9b93ecd8dd8e22.tar.bz2
[svn-r21710] CMake FindMPI module changed to look for fortran libs. Cmake files updated to link with fortran mpi libs.
Updated cacheinit.cmake to set num of procs to 3 for hdf testing. Tested: local linux and on windows 7
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index 1a6329f..4796187 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -1,6 +1,10 @@
cmake_minimum_required (VERSION 2.8)
PROJECT (HDF5_F90 C CXX Fortran)
+IF (H5_HAVE_PARALLEL)
+ FIND_PACKAGE (MPI)
+ENDIF (H5_HAVE_PARALLEL)
+
#-----------------------------------------------------------------------------
# Traverse source subdirectory
#-----------------------------------------------------------------------------
@@ -18,7 +22,7 @@ ENDIF (HDF5_BUILD_EXAMPLES)
#-----------------------------------------------------------------------------
IF (BUILD_TESTING)
ADD_SUBDIRECTORY (${HDF5_F90_SOURCE_DIR}/test ${HDF5_F90_BINARY_DIR}/test)
- IF (H5_HAVE_PARALLEL)
+ IF (MPI_Fortran_FOUND)
ADD_SUBDIRECTORY (${HDF5_F90_SOURCE_DIR}/testpar ${HDF5_F90_BINARY_DIR}/testpar)
- ENDIF (H5_HAVE_PARALLEL)
+ ENDIF (MPI_Fortran_FOUND)
ENDIF (BUILD_TESTING)