summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2010-05-25 16:00:56 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2010-05-25 16:00:56 (GMT)
commitef292895e9817f7134da9d4a6c7c0c699e01ae9e (patch)
treee488dfbd24af16f0dfc6ffdf518059cfa775271f /fortran/CMakeLists.txt
parent9f5a4ed901da65a3b5a6b63f75c99a5fe72c6832 (diff)
downloadhdf5-ef292895e9817f7134da9d4a6c7c0c699e01ae9e.zip
hdf5-ef292895e9817f7134da9d4a6c7c0c699e01ae9e.tar.gz
hdf5-ef292895e9817f7134da9d4a6c7c0c699e01ae9e.tar.bz2
[svn-r18890] Update CMake fortran configure/build with changes from community.
- Add an install rule to copy compiled fortran module files - Only build the xlatefile utility if testing and tools are enabled - Don't do MPI HAVE_XXX checks until MPI_FOUND is true - Install needs H5version.h & H5overflow.h to be copied - Add debug information flags to debug compile and link lines for win32 Intel compiler
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index a649fab..cf003ea 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -116,6 +116,16 @@ INCLUDE_DIRECTORIES(
)
#-----------------------------------------------------------------------------
+# Add debug information (intel Fortran : JB)
+#-----------------------------------------------------------------------------
+IF (CMAKE_Fortran_COMPILER MATCHES ifort)
+ IF (WIN32)
+ SET (CMAKE_Fortran_FLAGS_DEBUG "/debug:full " CACHE "flags" STRING FORCE)
+ SET (CMAKE_EXE_LINKER_FLAGS_DEBUG "/DEBUG" CACHE "flags" STRING FORCE)
+ ENDIF (WIN32)
+ENDIF (CMAKE_Fortran_COMPILER MATCHES ifort)
+
+#-----------------------------------------------------------------------------
# Traverse source subdirectory
#-----------------------------------------------------------------------------
ADD_SUBDIRECTORY (${HDF5_F90_SOURCE_DIR}/src ${HDF5_F90_BINARY_DIR}/src)