summaryrefslogtreecommitdiffstats
path: root/fortran/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2020-01-15 17:38:06 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2020-05-20 14:20:26 (GMT)
commit6682c717e263ed3f3465766f9664f3b7ff115841 (patch)
tree3be4f156651c4fef09a0f66779fd72f577618c7b /fortran/CMakeLists.txt
parent9ebf36e8937995ae88243164a914e0743a8bbbd6 (diff)
downloadhdf5-6682c717e263ed3f3465766f9664f3b7ff115841.zip
hdf5-6682c717e263ed3f3465766f9664f3b7ff115841.tar.gz
hdf5-6682c717e263ed3f3465766f9664f3b7ff115841.tar.bz2
HDFFV-11001 Add fine control over testing
Diffstat (limited to 'fortran/CMakeLists.txt')
-rw-r--r--fortran/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/fortran/CMakeLists.txt b/fortran/CMakeLists.txt
index 31edad2..9755963 100644
--- a/fortran/CMakeLists.txt
+++ b/fortran/CMakeLists.txt
@@ -23,8 +23,11 @@ endif ()
# Testing
#-----------------------------------------------------------------------------
if (BUILD_TESTING)
- add_subdirectory (test)
- if (MPI_Fortran_FOUND)
- add_subdirectory (testpar)
+ if (HDF5_TEST_SERIAL)
+ add_subdirectory (test)
+ endif ()
+ if (MPI_Fortran_FOUND AND HDF5_TEST_PARALLEL)
+ add_subdirectory (testpar)
+ endif ()
endif ()
endif ()