summaryrefslogtreecommitdiffstats
path: root/fortran/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-02-11 17:40:52 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-02-11 17:40:52 (GMT)
commit3f0a35a4eab869793f5b3882da35a2fe0b683dbd (patch)
tree35c5a256e137aa8e16c120b4a59feab2cbeb2fe0 /fortran/Makefile.am
parent54f376edbb1bce24bff19fb6b7c3d298470356be (diff)
downloadhdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.zip
hdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.tar.gz
hdf5-3f0a35a4eab869793f5b3882da35a2fe0b683dbd.tar.bz2
[svn-r9988] Purpose:
Bug fix Description: pmake (on modi4, for instance) complains about undefined variables if it is run without the -V flag, which turns those errors to warnings. Solution: Added test to configure.in to see if $MAKE will allow Makefiles with undefined variables. If not, sets -V flag in AM_MAKEFLAGS. Ensured that all custom make targets use AM_MAKEFLAGS. Also defined all variables that caused errors in top-level Makefile.am. This means that pmake can be used to build hdf5 *from the top level only*. To run make from a subdirectory, still need to use -V flag (or use make or gmake). Platforms tested: modi4, heping, copper, sleipnir
Diffstat (limited to 'fortran/Makefile.am')
-rw-r--r--fortran/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/fortran/Makefile.am b/fortran/Makefile.am
index 0d55334..06bd888 100644
--- a/fortran/Makefile.am
+++ b/fortran/Makefile.am
@@ -34,24 +34,24 @@ DIST_SUBDIRS=src test testpar examples
# Clean and mostlyclean need to recurse into examples directory
clean-local:
- if test -f examples/Makefile; then \
- (cd examples && $(MAKE) clean) || exit 1; \
+ if test -f examples/Makefile; then \
+ (cd examples && $(MAKE) $(AM_MAKEFLAGS) clean) || exit 1; \
fi;
mostlyclean-local:
- if test -f examples/Makefile; then \
- (cd examples && $(MAKE) mostlyclean) || exit 1; \
+ if test -f examples/Makefile; then \
+ (cd examples && $(MAKE) $(AM_MAKEFLAGS) mostlyclean) || exit 1; \
fi;
# Install examples
install-examples uninstall-examples:
- (cd examples && $(MAKE) $@) || exit 1;
+ (cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
# Check that examples can be successfully built
check-install:
- $(MAKE) installcheck
+ $(MAKE) $(AM_MAKEFLAGS) installcheck
installcheck-local:
- (cd examples && $(MAKE) $@) || exit 1;
+ (cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
include $(top_srcdir)/config/conclude.am