summaryrefslogtreecommitdiffstats
path: root/fortran/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-04-11 21:47:05 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-04-11 21:47:05 (GMT)
commitafef3c035864297dd2ffe537508164ecb87e89e4 (patch)
treecaefd3218d14685f69e90ebe2ab5b3fd4e32b0fd /fortran/Makefile.am
parent408471420f13327597fb9c87149bc1bc709f8740 (diff)
downloadhdf5-afef3c035864297dd2ffe537508164ecb87e89e4.zip
hdf5-afef3c035864297dd2ffe537508164ecb87e89e4.tar.gz
hdf5-afef3c035864297dd2ffe537508164ecb87e89e4.tar.bz2
[svn-r10587] Purpose:
Minor feature Description: If a user configures without C++ or Fortran, 'make' will not recurse into c++ or fortran directories. However, if the user cd's into these directories and 'makes,' the Makefiles will attempt to build interfaces that have not been configured, usually failing. In an unrelated but minor change, src/H5detect should be compiled with the -g flag to disable compiler optimizations since it is only executed once. Solution: Make it harder for users to try to compile interfaces that have not been configured by making c++, fortran, and hl directories not recurse into their subdirectories unless they have been configured. Thus, 'make' in /fortran/src will break if Fortran has not been configured, but 'make' in /fortran will not break. Platforms tested: mir, modi4, copper Misc. update:
Diffstat (limited to 'fortran/Makefile.am')
-rw-r--r--fortran/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/fortran/Makefile.am b/fortran/Makefile.am
index 06bd888..dce1857 100644
--- a/fortran/Makefile.am
+++ b/fortran/Makefile.am
@@ -28,7 +28,11 @@ if BUILD_PARALLEL_CONDITIONAL
endif
# Subdirectories in build order, not including examples directory
-SUBDIRS=src test $(TESTPARALLEL_DIR)
+## Only recurse into subdirectories if HDF5 is configured to use Fortran.
+if BUILD_FORTRAN_CONDITIONAL
+ SUBDIRS=src test $(TESTPARALLEL_DIR)
+endif
+
# All directories that have Makefiles
DIST_SUBDIRS=src test testpar examples