summaryrefslogtreecommitdiffstats
path: root/fortran/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2019-06-06 04:20:01 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2019-06-06 04:20:01 (GMT)
commit54a07f556cd2f3556f8c7946fe7905bc658a11aa (patch)
tree2563b439aa79df337a7d4b4ec884be0d535ee1b8 /fortran/Makefile.am
parent4af633d1c480deb7d27c1da7ee2c512a2500e543 (diff)
downloadhdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.zip
hdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.tar.gz
hdf5-54a07f556cd2f3556f8c7946fe7905bc658a11aa.tar.bz2
Add options to enable or disable building tools and tests. The default
is enabled for each.
Diffstat (limited to 'fortran/Makefile.am')
-rw-r--r--fortran/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/fortran/Makefile.am b/fortran/Makefile.am
index ca0733f..c07fa3e 100644
--- a/fortran/Makefile.am
+++ b/fortran/Makefile.am
@@ -22,14 +22,21 @@
include $(top_srcdir)/config/commence.am
-if BUILD_PARALLEL_CONDITIONAL
+if BUILD_TESTS_PARALLEL_CONDITIONAL
TESTPARALLEL_DIR=testpar
+else
+ TESTPARALLEL_DIR=
+endif
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR=test
+else
+ TESTSERIAL_DIR=
endif
# Subdirectories in build order, not including examples directory
## Only recurse into subdirectories if HDF5 is configured to use Fortran.
if BUILD_FORTRAN_CONDITIONAL
- SUBDIRS=src test $(TESTPARALLEL_DIR)
+ SUBDIRS=src $(TESTSERIAL_DIR) $(TESTPARALLEL_DIR)
# Test with just the native connector, with a single pass-through connector
# and with a doubly-stacked pass-through.