summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-04-10 00:48:46 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-04-10 00:48:46 (GMT)
commit44deb0bdec073dcd3c5041b0781e74b0ece759f6 (patch)
treec5011781c4480539f1f4ddaddee5ae908292479e /fortran/configure.in
parentbb0df72af60a300a9876914c6f6e14517d585450 (diff)
downloadhdf5-44deb0bdec073dcd3c5041b0781e74b0ece759f6.zip
hdf5-44deb0bdec073dcd3c5041b0781e74b0ece759f6.tar.gz
hdf5-44deb0bdec073dcd3c5041b0781e74b0ece759f6.tar.bz2
[svn-r6622] Purpose:
Addition Description: Added "h5fc" utility. This is the same as the "h5cc" utility but for Fortran. It only handles static libraries since that's the only library we build for Fortran. Note! I've tested the code on the normal platforms but I haven't tested the utility itself. Platforms tested: Arabica (Fortran) Modi4 (Fortran & Parallel) Burrwhite (Fortran & C++ Misc. update:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in22
1 files changed, 3 insertions, 19 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index e335fe1..423cef7 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -691,25 +691,6 @@ case "X-$enable_parallel" in
fi
;;
- X-mpich)
- dnl For normal mpich installation the compiler, mpicc, should know
- dnl where the MPI and MPI-IO header files are located and know which
- dnl extra libraries need to be linked and will supply appropriate
- dnl flags to the underlying compiler.
- AC_MSG_RESULT(mpich)
- AC_MSG_WARN(*** Why aren't you using an mpicc compiler? ***)
-
- dnl Apparently mpicc isn't installed correctly so configure must
- dnl search for the header files and libraries. Actually we only
- dnl have to search for the libraries in order to get the onto the
- dnl link line, the user will have already told us about the
- dnl locations. Fail if something is missing.
- PARALLEL=mpich
- AC_CHECK_FLIB(fmpich, [
- include 'mpif.h'
- call mpi_file_open( ierr )],, AC_MSG_ERROR(no mpich library))
- ;;
-
*)
AC_MSG_RESULT(error)
AC_MSG_ERROR(\'$enable_parallel\' is not a valid parallel search type)
@@ -920,6 +901,7 @@ AC_CONFIG_FILES([config/depend1
config/commence
config/conclude
Makefile
+ src/h5fc
src/H5fortran_types.f90
src/Makefile
test/Makefile
@@ -933,3 +915,5 @@ touch ./config/stamp2
dnl Finally the makefiles
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+
+chmod 755 src/h5fc