summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-09-09 20:01:49 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-09-09 20:01:49 (GMT)
commit85ebef607feb03b8e33deca2dce09a378a67963b (patch)
tree08d1054730c23db81e468bde06d1cb1b76e67ce6 /fortran/configure.in
parent0b99dd414c19b5dc63305253d08d1059d9c3a9f2 (diff)
downloadhdf5-85ebef607feb03b8e33deca2dce09a378a67963b.zip
hdf5-85ebef607feb03b8e33deca2dce09a378a67963b.tar.gz
hdf5-85ebef607feb03b8e33deca2dce09a378a67963b.tar.bz2
[svn-r5913] Purpose:
Bug Fix Description: We were getting the wrong MPIRUN program when you used the full pathname. The "case" statement was checking the "F9X" macro, but it really only needed the basename of the F9X macro. Solution: Put wildcard matching in so that it would find the appropriate basename. Platforms tested: Modi4
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 4009e4b..e894841 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -457,7 +457,7 @@ dnl executable. For `mpif90' the executable should be run with `mpirun'
dnl from the same directory as mpif90 if it exists.
dnl
case "$F9X" in
- mpif90)
+ *mpif90*)
dnl The mpich compiler. Use mpirun from the same directory if it
dnl exists.
PARALLEL=mpif90
@@ -488,7 +488,7 @@ case "$F9X" in
fi
;;
- mpxlf | mpxlf_r | mpxlf90 | mpxlf90_r | mpxlf95 | mpxlf95_r)
+ *mpxlf* | *mpxlf_r* | *mpxlf90* | *mpxlf90_r* | *mpxlf95* | *mpxlf95_r*)
dnl The IBM compiler
PARALLEL="$F9X"
;;