summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-05-15 23:26:09 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-05-15 23:26:09 (GMT)
commit723a19e588b8dc4f892522307f6d404c927e68f9 (patch)
treeda990d7ca373241548166ec50401c6bf25ff7187 /fortran/configure.in
parentb94cfc0ba0ffc764cefc25f31920feaa584cba76 (diff)
downloadhdf5-723a19e588b8dc4f892522307f6d404c927e68f9.zip
hdf5-723a19e588b8dc4f892522307f6d404c927e68f9.tar.gz
hdf5-723a19e588b8dc4f892522307f6d404c927e68f9.tar.bz2
[svn-r6880] Purpose:
Update Description: Added support for finding GPFS code. Platforms tested: Modi4 (Fortran & Parallel) Verbena (Fortran & C++) Arabica (Fortran) (though not with GPFS enabled...) Misc. update:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 404b356..25a01b8 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -957,6 +957,28 @@ EOF
rm makeinc maketest
fi
+dnl ----------------------------------------------------------------------
+dnl Checking to see if GPFS is available on this filesystem
+dnl
+
+dnl Change to the C language
+AC_LANG_C
+
+AC_CHECK_HEADERS([gpfs.h],
+ AC_MSG_CHECKING([for GPFS support])
+ AC_TRY_COMPILE([#include <gpfs.h>],
+ [int fd = 0; gpfs_fcntl(fd, (void *)0);],
+ AC_DEFINE(HAVE_GPFS, 1,
+ [Define if we have GPFS support])
+ AC_MSG_RESULT(yes)
+ LIBS="$LIBS -lgpfs"
+ GPFS="yes",
+ AC_MSG_RESULT(no)
+ GPFS="no"))
+
+dnl Change back to the Fortran 90 language
+AC_LANG_FORTRAN9X
+
dnl Some cleanup stuff
rm -f conftest core core.* *.core conftest.o conftest.c dummy.o $ac_clean_files