summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-08-01 21:16:47 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-08-01 21:16:47 (GMT)
commit90ab7aaaff53cd3ec87bf578e9c562f88219a965 (patch)
treeb999b15aacce93f1185920e128dae5cfc9e5ecbc /fortran/configure.in
parent40e63a9a7ce91a92254fec337fb7e1dbb32cfee0 (diff)
downloadhdf5-90ab7aaaff53cd3ec87bf578e9c562f88219a965.zip
hdf5-90ab7aaaff53cd3ec87bf578e9c562f88219a965.tar.gz
hdf5-90ab7aaaff53cd3ec87bf578e9c562f88219a965.tar.bz2
[svn-r4295]
Purpose: Back-port of Bug Fix Description: Back port from the 1.5 branch of the .depend/Dependencies files generation bug. (When the $srcdir et.al. macros began with a ".", they were lopping off the first character of a header file's path). Platforms tested: Linux
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 0004cca..f14c18a 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -134,6 +134,19 @@ AC_PROG_MAKE_SET
AC_PROG_INSTALL
AM_PROG_LIBTOOL
+dnl ----------------------------------------------------------------------
+dnl Check if they have Perl installed on their system. We only need Perl
+dnl if they're using a GNU compiler.
+dnl
+AC_SUBST(PERL) PERL=""
+if test "X$GCC" = "Xyes"; then
+ AC_CHECK_PROGS(PERL, perl,, $PATH)
+fi
+
+dnl ----------------------------------------------------------------------
+dnl Check which archiving tool to use. This needs to be done before
+dnl the AM_PROG_LIBTOOL macro.
+dnl
if test -z "$AR"; then
AC_CHECK_PROGS(AR,ar xar,:,$PATH)
fi