summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-07-06 19:46:56 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-07-06 19:46:56 (GMT)
commit208e185f6a19d8e27e1c12c7678ce17fad0f26ee (patch)
treea596bd5a0fcdb5275c7e76b1a72e08b2bdc3e212 /fortran/configure.in
parent6f5d2e89abd4480da0fd1b844a316edb6db88dde (diff)
downloadhdf5-208e185f6a19d8e27e1c12c7678ce17fad0f26ee.zip
hdf5-208e185f6a19d8e27e1c12c7678ce17fad0f26ee.tar.gz
hdf5-208e185f6a19d8e27e1c12c7678ce17fad0f26ee.tar.bz2
[svn-r4138]
Purpose: Bug Fix Description: In order for libtool to point to the place zlib lives (when specified) it needs to add that flag to the LDFLAGS macro. However, since we're getting this information from the top-level configure, it's cached. Thus, we don't check for it and the -L flag doesn't get included into the LDFLAGS macro. Solution: Remove the cached value so that the Fortran configure will always check for zlib even if it's found by the top-level configure. Platforms tested: Kelgia
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index c890232..5463d99 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -252,6 +252,13 @@ dnl Is the GNU zlib present? It has a header file `zlib.h' and a library
dnl `-lz' and their locations might be specified with the `--enable-zlib'
dnl command-line switch. The value is an include path and/or a library path.
dnl If the library path is specified then it must be preceded by a comma.
+
+dnl If the presence of zlib is already cached by the top-level configure,
+dnl then "uncache" it so that we will go through this logic in any case.
+dnl Some systems where you need to specify exactly where the zlib is need
+dnl this.
+ac_cv_lib_z_compress=""
+
AC_ARG_WITH(zlib,[ --with-zlib=INC,LIB Use the GNU zlib compression],
,withval=yes)
case "$withval" in