summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 20:02:26 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 20:02:26 (GMT)
commit24edaaf9f03c74c1bcc6959ba355ac80be2e080f (patch)
treeff2869517330cbae853854899ac0fe45239374d0 /fortran/configure.in
parentf980ab403a3dc56ecff2631fb664e78dc3cd0afe (diff)
downloadhdf5-24edaaf9f03c74c1bcc6959ba355ac80be2e080f.zip
hdf5-24edaaf9f03c74c1bcc6959ba355ac80be2e080f.tar.gz
hdf5-24edaaf9f03c74c1bcc6959ba355ac80be2e080f.tar.bz2
[svn-r5235] Purpose:
Update Description: Updated the way we used the AC_INIT macros so that it's current to the new standard way and not deprecated anymore. Also, added a test for some functions during parallel Fortran configure. This required the creation of an H5config_fortran.h file so that we can test for these... Platforms tested: Elena is going to test the changes to the fortran after she checks in her other code. I will test on SDSC machines after getting her code. The other changes were tested on Linux.
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in47
1 files changed, 44 insertions, 3 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index b013810..62533ed 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -10,8 +10,20 @@ dnl ----------------------------------------------------------------------
dnl Initialize configure.
dnl
AC_REVISION($Id$)
-AC_INIT(src/HDF5.f90)
-AC_CONFIG_AUX_DIR(../bin)
+
+dnl AC_INIT takes the name of the package, the version number, and an
+dnl email address to report bugs. AC_CONFIG_SRCDIR takes a unique file
+dnl as its argument.
+dnl
+dnl NOTE: Don't forget to change the version number here when we do a
+dnl release!!!
+dnl
+AC_INIT([HDF5 Fortran], [1.5], [hdfhelp@ncsa.uiuc.edu])
+AC_CONFIG_SRCDIR([src/HDF5.f90])
+AC_CONFIG_HEADER([src/H5config_fortran.h])
+
+AC_CONFIG_AUX_DIR([../bin])
+
AC_CANONICAL_HOST
AC_SUBST(CPPFLAGS)
AC_SUBST(FFLAGS)
@@ -531,6 +543,35 @@ if test -n "$PARALLEL"; then
fi
ADD_PARALLEL_FILES="yes"
+
+ AC_MSG_CHECKING([for MPI_Comm_c2f and MPI_Comm_f2c functions])
+
+ dnl Change to the C language
+ AC_LANG_C
+
+ AC_TRY_COMPILE([
+#include <mpi.h>
+ ],
+ [MPI_Comm_c2f(); return 0;],
+ AC_DEFINE(HAVE_MPI_MULTI_LANG_Comm, 1,
+ [Define if \`MPI_Comm_c2f' and \`MPI_Comm_f2c' exists])
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+ )
+
+ AC_MSG_CHECKING([for MPI_Info_c2f and MPI_Info_f2c functions])
+ AC_TRY_COMPILE([
+#include <mpi.h>
+ ],
+ [MPI_Info_c2f(); return 0;],
+ AC_DEFINE(HAVE_MPI_MULTI_LANG_Info, 1,
+ [Define if \`MPI_Info_c2f' and \`MPI_Info_f2c' exists])
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+ )
+
+ dnl Change to the Fortran 90 language
+ AC_LANG_FORTRAN9X
fi
AC_SUBST(ADD_PARALLEL_FILES)
@@ -672,7 +713,7 @@ AC_CONFIG_FILES([config/depend1
AC_OUTPUT
no_create=$saved_no_create
-dnl Then the stamp2 file for H5config.h
+dnl Then the stamp2 file for H5config_fortran.h
touch ./config/stamp2
dnl Finally the makefiles