summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-10-31 20:19:03 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-10-31 20:19:03 (GMT)
commit284b19a05fc6fdfff21e4c60d6396a3e75ca211a (patch)
tree0e7414efe7c3b1d7d039ac69f8c806587e1128c5 /fortran/configure.in
parent350fa2af782285de92e947cb29ab0c207867aacb (diff)
downloadhdf5-284b19a05fc6fdfff21e4c60d6396a3e75ca211a.zip
hdf5-284b19a05fc6fdfff21e4c60d6396a3e75ca211a.tar.gz
hdf5-284b19a05fc6fdfff21e4c60d6396a3e75ca211a.tar.bz2
[svn-r2782] Purpose:
Feature Description: This will run the parallel test files for Fortran when --enable-parallel is specified Platforms tested: Modi4
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 8181693..c367674 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -429,6 +429,13 @@ case "X-$enable_parallel" in
esac
dnl ----------------------------------------------------------------------
+dnl Should the `testpar' directory participate in the build?
+dnl
+if test -n "$PARALLEL"; then
+ TESTPARALLEL=testpar
+fi
+
+dnl ----------------------------------------------------------------------
dnl Print some other parallel information and do some sanity checks.
dnl
ADD_PARALLEL_FILES=""
@@ -584,7 +591,7 @@ no_create=yes
AC_OUTPUT(config/depend1 config/depend2 config/depend3 config/depend4 \
config/dependN config/commence config/conclude Makefile \
src/H5fortran_types.f90 src/Makefile test/Makefile \
- examples/Makefile)
+ testpar/Makefile examples/Makefile)
no_create=$saved_no_create
dnl Then the stamp2 file for H5config.h