summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2001-03-22 19:08:02 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2001-03-22 19:08:02 (GMT)
commit4432a558f91d7eb81a3eea9b0c6155b62b4ce342 (patch)
tree2d9d9d6afa09788e25dbf9b00accfef99e201576 /fortran/configure.in
parent8f950835004165557a3425944c8691107f590756 (diff)
downloadhdf5-4432a558f91d7eb81a3eea9b0c6155b62b4ce342.zip
hdf5-4432a558f91d7eb81a3eea9b0c6155b62b4ce342.tar.gz
hdf5-4432a558f91d7eb81a3eea9b0c6155b62b4ce342.tar.bz2
[svn-r3693] Purpose:
Bug Fix Description: Create a Makefile in the testpar/ directory only if PARALLEL is enabled. Solution: Set a macro to the testpar/Makefile for the generation script.
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index eaaa75a..35081e7 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -606,13 +606,28 @@ dnl First the stamp1 file for H5config.h.in
mkdir ./config >/dev/null 2>&1
touch ./config/stamp1
+PARALLEL_MAKE=
+
+if test -n "$TESTPARALLEL"; then
+ PARALLEL_MAKE=$TESTPARALLEL/Makefile
+fi
+
dnl Then the config.status file (but not makefiles)
saved_no_create=$no_create
no_create=yes
-AC_OUTPUT(config/depend1 config/depend2 config/depend3 config/depend4 \
- config/dependN config/commence config/conclude Makefile \
- src/H5fortran_types.f90 src/Makefile test/Makefile \
- testpar/Makefile examples/Makefile)
+AC_OUTPUT(config/depend1
+ config/depend2
+ config/depend3
+ config/depend4
+ config/dependN
+ config/commence
+ config/conclude
+ Makefile
+ src/H5fortran_types.f90
+ src/Makefile
+ test/Makefile
+ $PARALLEL_MAKE
+ examples/Makefile)
no_create=$saved_no_create
dnl Then the stamp2 file for H5config.h