summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2003-04-23 19:25:58 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2003-04-23 19:25:58 (GMT)
commit7927acd7f31e2fb4136ac7e1826dc07a758ef11f (patch)
tree784becd8674ccab6265e13814a36ae0ff34d68c3 /fortran/configure.in
parent46cb3df9f5cd100c77f2e8a8f4bc7b7c8dafd2b0 (diff)
downloadhdf5-7927acd7f31e2fb4136ac7e1826dc07a758ef11f.zip
hdf5-7927acd7f31e2fb4136ac7e1826dc07a758ef11f.tar.gz
hdf5-7927acd7f31e2fb4136ac7e1826dc07a758ef11f.tar.bz2
[svn-r6739] Purpose:
Bug Fix Description: H5FC was failing on Copper (IBM P690). The reason: the xlf compiler needs files to end in .f in stead of .f90. If you have .f90 files, you need the "-qsuffix=f=f90" flag defined. This was defined for compiling things via the "-c" option (to object files) but not for straight compilation of a file. I also noticed that the directory modules were being extracted from was "." and "../src". H5FC would find these alright when doing a "make check-install" but if Suzie User were to try this, it might fail for her. Suzie would have to specify explicitly where to grab these files. Solution: The solution to the problem was a bit more involved. I added a new variable called "F9XSUFFIXFLAG" which is set to this value if the machine needs it. Added new variable called "FSEARCH_DIRS" which can be set to the directories to find modules during compilation. The H5FC script knows where to find the correct modules (it's in the lib/ directory), so it uses the F9XMODFLAG to find them and not the FSEARCH_DIRS flag. Platforms tested: Modi4 (Fortran & Parallel) Verbena (Fortran) C++ not needed since this is Fortran-only fix Arabica (Fortran) Copper (Fortran) Ran "make install" and "make check-install" afterwards... Misc. update:
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in25
1 files changed, 14 insertions, 11 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index f5a3d4e..e537548 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -48,6 +48,7 @@ AC_OUTPUT_COMMANDS([
AC_CANONICAL_HOST
AC_SUBST(CPPFLAGS)
AC_SUBST(FFLAGS)
+AC_SUBST(FSEARCH_DIRS)
dnl ----------------------------------------------------------------------
dnl HDF5 integer variables for the H5fortran_types.f90 file.
@@ -141,16 +142,16 @@ esac
host_config="none"
for f in $host_cpu-$host_vendor-$host_os \
- $host_cpu-$host_vendor-$host_os_novers \
- $host_vendor-$host_os \
- $host_vendor-$host_os_novers \
- $host_cpu-$host_os \
- $host_cpu-$host_os_novers \
- $host_cpu-$host_vendor \
- $host_os \
- $host_os_novers \
- $host_vendor \
- $host_cpu ; do
+ $host_cpu-$host_vendor-$host_os_novers \
+ $host_vendor-$host_os \
+ $host_vendor-$host_os_novers \
+ $host_cpu-$host_os \
+ $host_cpu-$host_os_novers \
+ $host_cpu-$host_vendor \
+ $host_os \
+ $host_os_novers \
+ $host_vendor \
+ $host_cpu ; do
AC_MSG_CHECKING(for config $f)
if test -f $srcdir/config/$f; then
host_config=$srcdir/config/$f
@@ -164,6 +165,8 @@ if test "X$host_config" != "Xnone"; then
. $host_config
fi
+AC_SUBST(F9XSUFFIXFLAG)
+
dnl ----------------------------------------------------------------------
dnl Check for programs.
dnl
@@ -317,8 +320,8 @@ AC_CHECK_LIB([m], [ceil])
if test "`uname`" = "SunOS" -o "`uname -sr`" = "HP-UX B.11.00"; then
dnl ...for Solaris
- AC_CHECK_LIB([nsl], [xdr_int])
AC_CHECK_LIB([socket], [socket])
+ AC_CHECK_LIB([nsl], [xdr_int])
fi
dnl ----------------------------------------------------------------------