summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 22:16:47 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 22:16:47 (GMT)
commitb5c1eb3a612e5e3b930c1d1e04864f934be01630 (patch)
tree6bd2c1d99806f39d7a2f7179065ace9b48c5591f /fortran/configure.in
parent835a51fd9dfaa601c518326ade5f114e19165433 (diff)
downloadhdf5-b5c1eb3a612e5e3b930c1d1e04864f934be01630.zip
hdf5-b5c1eb3a612e5e3b930c1d1e04864f934be01630.tar.gz
hdf5-b5c1eb3a612e5e3b930c1d1e04864f934be01630.tar.bz2
[svn-r5241] Purpose:
Fix Description: When doing a TRY_LINK, the compiler complained about lack of parameters being passed to the function. Solution: Added the parameter it wants...
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index dd7bcd4..a27db47 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -552,7 +552,7 @@ if test -n "$PARALLEL"; then
AC_TRY_LINK([
#include <mpi.h>
],
- [MPI_Comm_c2f()],
+ [MPI_Comm c_comm; MPI_Comm_c2f(c_comm)],
AC_DEFINE(HAVE_MPI_MULTI_LANG_Comm, 1,
[Define if \`MPI_Comm_c2f' and \`MPI_Comm_f2c' exists])
AC_MSG_RESULT(yes),
@@ -563,7 +563,7 @@ if test -n "$PARALLEL"; then
AC_TRY_LINK([
#include <mpi.h>
],
- [MPI_Info_c2f()],
+ [MPI_Info c_info; MPI_Info_c2f(c_info)],
AC_DEFINE(HAVE_MPI_MULTI_LANG_Info, 1,
[Define if \`MPI_Info_c2f' and \`MPI_Info_f2c' exists])
AC_MSG_RESULT(yes),