summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-10-11 17:44:40 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-10-11 17:44:40 (GMT)
commitd1e73b09091a18a9872cd9e4ffea35fbf3bbe20b (patch)
tree529149e53d980ad24c908f1dab69f3d5acc24aaf /fortran/configure.in
parent714b3018f34fbaa75de9395418a6354debe12f76 (diff)
downloadhdf5-d1e73b09091a18a9872cd9e4ffea35fbf3bbe20b.zip
hdf5-d1e73b09091a18a9872cd9e4ffea35fbf3bbe20b.tar.gz
hdf5-d1e73b09091a18a9872cd9e4ffea35fbf3bbe20b.tar.bz2
[svn-r2669] Purpose:
Bug Fix Description: I was relying on the PARALLEL macro to be "yes" or "no" all the time. This isn't the case. Solution: Created the ADD_PARALLEL_FILES macro to do just this. Platforms tested: Modi4
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index bf91d91..3467378 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -431,6 +431,7 @@ esac
dnl ----------------------------------------------------------------------
dnl Print some other parallel information and do some sanity checks.
dnl
+ADD_PARALLEL_FILES=""
if test -n "$PARALLEL"; then
dnl We are building a parallel library
AC_DEFINE(HAVE_PARALLEL)
@@ -462,7 +463,10 @@ if test -n "$PARALLEL"; then
if test "X$RUNPARALLEL" = "Xnone"; then
RUNPARALLEL=
fi
+
+ ADD_PARALLEL_FILES="yes"
fi
+AC_SUBST(ADD_PARALLEL_FILES)
AC_MSG_CHECKING(make)
AC_SUBST_FILE(DEPEND)