summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2000-11-14 23:17:32 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2000-11-14 23:17:32 (GMT)
commite7612be4887d7adb0fb2fd42a291693e30e96974 (patch)
treef4df36ef9c6a7c2fe737be1f3ace8964c177e26b /fortran/configure.in
parente558d37f0fca58c332b3d0b102deab09e376e69b (diff)
downloadhdf5-e7612be4887d7adb0fb2fd42a291693e30e96974.zip
hdf5-e7612be4887d7adb0fb2fd42a291693e30e96974.tar.gz
hdf5-e7612be4887d7adb0fb2fd42a291693e30e96974.tar.bz2
[svn-r2905] Purpose:
Bug Description: Applied the DYNAMIC_DIRS patch to this configure file. It was applied to the hdf5 stuff but didn't make it down here.
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in16
1 files changed, 10 insertions, 6 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index c367674..618094e 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -537,15 +537,19 @@ dnl
DYNAMIC_DIRS=""
if test -n "$LDFLAGS"; then
for d in $LDFLAGS ; do
- d=`echo $d | sed -e 's/-L//g'`
case "$d" in
- .*)
- dnl If the path isn't absolute, make it so by prepending the
- dnl ROOT directory to it.
- d=${ROOT}/$d
+ -L*)
+ d=`echo $d | sed -e 's/-L//g'`
+ case "$d" in
+ .*)
+ dnl If the path isn't absolute, make it so by prepending the
+ dnl ROOT directory to it.
+ d=${ROOT}/$d
+ ;;
+ esac
+ DYNAMIC_DIRS="-R${d} $DYNAMIC_DIRS"
;;
esac
- DYNAMIC_DIRS="-R${d} $DYNAMIC_DIRS"
done
fi
AC_SUBST(DYNAMIC_DIRS)