summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 22:02:46 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 22:02:46 (GMT)
commit6b4bfb60db8262d4321b729bab46f726157c02e7 (patch)
tree6810cb9a5a6966449e0ebcb7bc638f77866932cc /fortran/configure.in
parentf1fca69547262adac2e841e76c4ac9df5f32b2f5 (diff)
downloadhdf5-6b4bfb60db8262d4321b729bab46f726157c02e7.zip
hdf5-6b4bfb60db8262d4321b729bab46f726157c02e7.tar.gz
hdf5-6b4bfb60db8262d4321b729bab46f726157c02e7.tar.bz2
[svn-r5239] Purpose:
Fix Description: Needed to test if the test programs LINK not just COMPILE... Solution: Changed the macro from COMPILE to LINK.
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 62533ed..4ce66dc 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -549,7 +549,7 @@ if test -n "$PARALLEL"; then
dnl Change to the C language
AC_LANG_C
- AC_TRY_COMPILE([
+ AC_TRY_LINK([
#include <mpi.h>
],
[MPI_Comm_c2f(); return 0;],
@@ -560,7 +560,7 @@ if test -n "$PARALLEL"; then
)
AC_MSG_CHECKING([for MPI_Info_c2f and MPI_Info_f2c functions])
- AC_TRY_COMPILE([
+ AC_TRY_LINK([
#include <mpi.h>
],
[MPI_Info_c2f(); return 0;],