summaryrefslogtreecommitdiffstats
path: root/fortran/configure.in
diff options
context:
space:
mode:
authorBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 22:05:27 (GMT)
committerBill Wendling <wendling@ncsa.uiuc.edu>2002-04-23 22:05:27 (GMT)
commit835a51fd9dfaa601c518326ade5f114e19165433 (patch)
tree2f6a6111e640fd31f94161c268b19501063fab9e /fortran/configure.in
parent6b4bfb60db8262d4321b729bab46f726157c02e7 (diff)
downloadhdf5-835a51fd9dfaa601c518326ade5f114e19165433.zip
hdf5-835a51fd9dfaa601c518326ade5f114e19165433.tar.gz
hdf5-835a51fd9dfaa601c518326ade5f114e19165433.tar.bz2
[svn-r5240] Purpose:
Cleanup Solution: An even better way of using the AC_TRY_LINK macro...
Diffstat (limited to 'fortran/configure.in')
-rw-r--r--fortran/configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/configure.in b/fortran/configure.in
index 4ce66dc..dd7bcd4 100644
--- a/fortran/configure.in
+++ b/fortran/configure.in
@@ -552,7 +552,7 @@ if test -n "$PARALLEL"; then
AC_TRY_LINK([
#include <mpi.h>
],
- [MPI_Comm_c2f(); return 0;],
+ [MPI_Comm_c2f()],
AC_DEFINE(HAVE_MPI_MULTI_LANG_Comm, 1,
[Define if \`MPI_Comm_c2f' and \`MPI_Comm_f2c' exists])
AC_MSG_RESULT(yes),
@@ -563,7 +563,7 @@ if test -n "$PARALLEL"; then
AC_TRY_LINK([
#include <mpi.h>
],
- [MPI_Info_c2f(); return 0;],
+ [MPI_Info_c2f()],
AC_DEFINE(HAVE_MPI_MULTI_LANG_Info, 1,
[Define if \`MPI_Info_c2f' and \`MPI_Info_f2c' exists])
AC_MSG_RESULT(yes),