summaryrefslogtreecommitdiffstats
path: root/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-02 17:19:30 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-02 17:19:30 (GMT)
commitc6827191f928a44012d200aaaa5319c603a700bd (patch)
treef7b89a114041e644f554967a15d6ad000971754f /fortran/examples/CMakeLists.txt
parent6dd91d206f6177585a32d0449bcb9abd6792c8a4 (diff)
downloadhdf5-c6827191f928a44012d200aaaa5319c603a700bd.zip
hdf5-c6827191f928a44012d200aaaa5319c603a700bd.tar.gz
hdf5-c6827191f928a44012d200aaaa5319c603a700bd.tar.bz2
TRILABS-19 fix syntax for windows
Diffstat (limited to 'fortran/examples/CMakeLists.txt')
-rw-r--r--fortran/examples/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/fortran/examples/CMakeLists.txt b/fortran/examples/CMakeLists.txt
index aa2d138..ad3c9c6 100644
--- a/fortran/examples/CMakeLists.txt
+++ b/fortran/examples/CMakeLists.txt
@@ -63,7 +63,7 @@ foreach (example ${examples})
)
target_compile_options(f90_ex_${example}-shared
PRIVATE
- $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"/dll">
+ $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:/dll>
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
target_link_libraries (f90_ex_${example}-shared
@@ -111,7 +111,7 @@ foreach (example ${F2003_examples})
)
target_compile_options(f03_ex_${example}-shared
PRIVATE
- $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"/dll">
+ $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:/dll>
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
target_link_libraries (f03_ex_${example}-shared
@@ -159,7 +159,7 @@ if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
)
target_compile_options(f90_ex_ph5example-shared
PRIVATE
- $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:"/dll">
+ $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:/dll>
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
target_link_libraries (f90_ex_ph5example-shared