summaryrefslogtreecommitdiffstats
path: root/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-05-22 20:48:34 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-05-22 20:48:34 (GMT)
commit7c4598cf740747530005e09363c379bbcfe93501 (patch)
tree1da957400563a2fb8357b90c49b1173aece0c216 /fortran/examples/CMakeLists.txt
parenteb8d35dd8cfd7339c203f758cf9637ac1cdc7a96 (diff)
downloadhdf5-7c4598cf740747530005e09363c379bbcfe93501.zip
hdf5-7c4598cf740747530005e09363c379bbcfe93501.tar.gz
hdf5-7c4598cf740747530005e09363c379bbcfe93501.tar.bz2
Remove link flag from compile command
Diffstat (limited to 'fortran/examples/CMakeLists.txt')
-rw-r--r--fortran/examples/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/fortran/examples/CMakeLists.txt b/fortran/examples/CMakeLists.txt
index cc14651..c836c17 100644
--- a/fortran/examples/CMakeLists.txt
+++ b/fortran/examples/CMakeLists.txt
@@ -69,7 +69,6 @@ foreach (example ${examples})
)
target_compile_options(f90_ex_${example}-shared
PRIVATE
- $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:/dll>
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
target_link_libraries (f90_ex_${example}-shared
@@ -129,7 +128,6 @@ foreach (example ${F2003_examples})
)
target_compile_options(f03_ex_${example}-shared
PRIVATE
- $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:/dll>
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
target_link_libraries (f03_ex_${example}-shared
@@ -189,7 +187,6 @@ if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
)
target_compile_options(f90_ex_ph5example-shared
PRIVATE
- $<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:/dll>
$<$<STREQUAL:"x${CMAKE_Fortran_SIMULATE_ID}","xMSVC">:${WIN_COMPILE_FLAGS}>
)
target_link_libraries (f90_ex_ph5example-shared