summaryrefslogtreecommitdiffstats
path: root/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2017-11-01 17:29:53 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2017-11-01 17:29:53 (GMT)
commit930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea (patch)
tree3a3f4330b3cf840f2ce47249607d25ca3935d8cb /fortran/examples/CMakeLists.txt
parent765d96456298aa678c072df9debba7d4be6ffb95 (diff)
downloadhdf5-930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea.zip
hdf5-930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea.tar.gz
hdf5-930cfc402dc2f17b1dbe9a6b3c5e15b95cc4c7ea.tar.bz2
Convert to use MPI:: for link
Diffstat (limited to 'fortran/examples/CMakeLists.txt')
-rw-r--r--fortran/examples/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/examples/CMakeLists.txt b/fortran/examples/CMakeLists.txt
index a5c3422..119648f 100644
--- a/fortran/examples/CMakeLists.txt
+++ b/fortran/examples/CMakeLists.txt
@@ -107,7 +107,7 @@ if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
target_link_libraries (f90_ex_ph5example
${HDF5_F90_LIB_TARGET}
${HDF5_LIB_TARGET}
- ${MPI_Fortran_LIBRARIES}
+ MPI::MPI_Fortran
)
target_include_directories (f90_ex_ph5example PRIVATE ${CMAKE_Fortran_MODULE_DIRECTORY}/static)
set_target_properties (f90_ex_ph5example PROPERTIES
@@ -122,7 +122,7 @@ if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
target_link_libraries (f90_ex_ph5example-shared
${HDF5_F90_LIBSH_TARGET}
${HDF5_LIBSH_TARGET}
- ${MPI_Fortran_LIBRARIES}
+ MPI::MPI_Fortran
)
target_include_directories (f90_ex_ph5example-shared PRIVATE ${CMAKE_Fortran_MODULE_DIRECTORY}/shared)
set_target_properties (f90_ex_ph5example-shared PROPERTIES