summaryrefslogtreecommitdiffstats
path: root/fortran/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorMohamad Chaarawi <chaarawi@hdfgroup.org>2014-06-11 13:44:37 (GMT)
committerMohamad Chaarawi <chaarawi@hdfgroup.org>2014-06-11 13:44:37 (GMT)
commit3e1e5f166a1316573ea81b96178bb6a4fa3654a2 (patch)
tree117c2d8a7a50c4b345784738bdc776ec540fc1db /fortran/examples/CMakeLists.txt
parent72e8017eadf211257caceb43095b2aed76e81632 (diff)
parentd86717819242c706a34abf2d2bdb64baebfe1818 (diff)
downloadhdf5-3e1e5f166a1316573ea81b96178bb6a4fa3654a2.zip
hdf5-3e1e5f166a1316573ea81b96178bb6a4fa3654a2.tar.gz
hdf5-3e1e5f166a1316573ea81b96178bb6a4fa3654a2.tar.bz2
[svn-r25254] merge from trunk.
Diffstat (limited to 'fortran/examples/CMakeLists.txt')
-rw-r--r--fortran/examples/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/fortran/examples/CMakeLists.txt b/fortran/examples/CMakeLists.txt
index 6f11895..322ae35 100644
--- a/fortran/examples/CMakeLists.txt
+++ b/fortran/examples/CMakeLists.txt
@@ -42,12 +42,12 @@ foreach (example ${examples})
add_executable (f90_ex_${example} ${HDF5_F90_EXAMPLES_SOURCE_DIR}/${example}.f90)
TARGET_NAMING (f90_ex_${example} ${LIB_TYPE})
TARGET_FORTRAN_PROPERTIES (f90_ex_${example} " " " ")
- if (WIN32 AND NOT CYGWIN)
+ if (WIN32)
set_property (TARGET f90_ex_${example}
APPEND PROPERTY COMPILE_DEFINITIONS
HDF5F90_WINDOWS
)
- endif (WIN32 AND NOT CYGWIN)
+ endif (WIN32)
target_link_libraries (f90_ex_${example}
${HDF5_F90_LIB_TARGET}
${HDF5_LIB_TARGET}
@@ -61,11 +61,11 @@ if (HDF5_ENABLE_F2003)
add_executable (f03_ex_${example} ${HDF5_F90_EXAMPLES_SOURCE_DIR}/${example}.f90)
TARGET_NAMING (f03_ex_${example} ${LIB_TYPE})
TARGET_FORTRAN_PROPERTIES (f03_ex_${example} " " " ")
- if (WIN32 AND NOT CYGWIN)
+ if (WIN32)
set_property (TARGET f03_ex_${example}
APPEND PROPERTY COMPILE_DEFINITIONS HDF5F90_WINDOWS
)
- endif (WIN32 AND NOT CYGWIN)
+ endif (WIN32)
target_link_libraries (f03_ex_${example}
${HDF5_F90_LIB_TARGET}
${HDF5_LIB_TARGET}
@@ -79,12 +79,12 @@ if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
add_executable (f90_ex_ph5example ${HDF5_F90_EXAMPLES_SOURCE_DIR}/ph5example.f90)
TARGET_NAMING (f90_ex_ph5example ${LIB_TYPE})
TARGET_FORTRAN_PROPERTIES (f90_ex_ph5example " " " ")
- if (WIN32 AND NOT CYGWIN)
+ if (WIN32)
set_property (TARGET f90_ex_ph5example
APPEND PROPERTY COMPILE_DEFINITIONS
HDF5F90_WINDOWS
)
- endif (WIN32 AND NOT CYGWIN)
+ endif (WIN32)
target_link_libraries (f90_ex_ph5example
${HDF5_F90_LIB_TARGET}
${HDF5_LIB_TARGET}