summaryrefslogtreecommitdiffstats
path: root/fortran/examples/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2014-04-09 04:55:49 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2014-04-09 04:55:49 (GMT)
commitf32690b53c0872faf9e9ee0d0492cce360f72938 (patch)
treea34e9d414dc486bd58509dd8671d44d9d22a6879 /fortran/examples/Makefile.am
parenta2c8dc8972a5b757ec94fa60a91559bc599db8ec (diff)
downloadhdf5-f32690b53c0872faf9e9ee0d0492cce360f72938.zip
hdf5-f32690b53c0872faf9e9ee0d0492cce360f72938.tar.gz
hdf5-f32690b53c0872faf9e9ee0d0492cce360f72938.tar.bz2
[svn-r24997] Added compiler versions for mpich to settings file and configure summary.
For make installcheck, compile and run installed examples using the installed scripts. They were being compiled but not run. Add Fortran2003 examples to the run-ex-fortran script when fortran2003 is enabled. Set flag to -O3 in production mode for Intel compilers other than those with specified other settings. Gentoo patches: Remove unnecessary setting of LD_LIBRARY_PATH from configure. Prevent potential array subscript out of bounds error in perform/pio_engine.c and sio_engine.c. Tested with h5committest on jam, koala, ostrich and platypus, on emu and kite, and parallel tests on jam, koala and platypus with mpich built with gnu 4.8.2 and with intel compilers.
Diffstat (limited to 'fortran/examples/Makefile.am')
-rw-r--r--fortran/examples/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/fortran/examples/Makefile.am b/fortran/examples/Makefile.am
index e994d4e..feed32c 100644
--- a/fortran/examples/Makefile.am
+++ b/fortran/examples/Makefile.am
@@ -26,6 +26,8 @@ if BUILD_PARALLEL_CONDITIONAL
EXAMPLE_PROG_PARA=ph5example
endif
+INSTALL_SCRIPT_FILES = run-fortran-ex.sh
+
# These are the programs that 'make all' or 'make tests' will build and
# that 'make check' will run. List them in the order in which they should
# be run.
@@ -41,7 +43,6 @@ INSTALL_FILES=h5_crtdat.f90 h5_rdwt.f90 \
h5_crtatt.f90 h5_crtgrp.f90 h5_crtgrpar.f90 h5_crtgrpd.f90 \
h5_extend.f90 h5_subset.f90 h5_cmprss.f90 hyperslab.f90 selectele.f90 refobjexample.f90 \
refregexample.f90 mountexample.f90 compound.f90 ph5example.f90
-INSTALL_SCRIPT_FILES = run-fortran-ex.sh
# Add attention tests for Fortran 2003 features
@@ -52,6 +53,7 @@ if FORTRAN_2003_CONDITIONAL_F
compound_fortran2003.f90 compound_complex_fortran2003.f90
endif
TEST_SCRIPT=testh5fc.sh
+TEST_EXAMPLES_SCRIPT=$(INSTALL_SCRIPT_FILES)
# Mark this directory as part of the Fortran API
FORTRAN_API=yes