summaryrefslogtreecommitdiffstats
path: root/fortran/examples/Makefile.am
diff options
context:
space:
mode:
authorDavid Young <dyoung@hdfgroup.org>2019-10-03 20:56:34 (GMT)
committerDavid Young <dyoung@hdfgroup.org>2019-12-19 21:03:41 (GMT)
commitbe8c2117b608a9ce43d3a112230159811d30cea2 (patch)
tree5944ae27ed39637da7800601b9fead8aa9c26b6f /fortran/examples/Makefile.am
parent126963be0ed9f059b85d400f1d43415275ce1dfa (diff)
downloadhdf5-be8c2117b608a9ce43d3a112230159811d30cea2.zip
hdf5-be8c2117b608a9ce43d3a112230159811d30cea2.tar.gz
hdf5-be8c2117b608a9ce43d3a112230159811d30cea2.tar.bz2
Let us override the examples directory using --with-examplesdir=DIR.
This is handy for NetBSD where HDF5 examples are installed by convention in $prefix/share/examples/hdf5/ rather than in ${prefix}/share/hdf5_examples/, which is the HDF5 default. Place hdf5_examples/ under ${datarootdir} which on most systems will be ${prefix}/share/, anyway.
Diffstat (limited to 'fortran/examples/Makefile.am')
-rw-r--r--fortran/examples/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/examples/Makefile.am b/fortran/examples/Makefile.am
index 6bf2edb..fb510bc 100644
--- a/fortran/examples/Makefile.am
+++ b/fortran/examples/Makefile.am
@@ -74,8 +74,8 @@ endif
# Tell automake how to install examples
# Note: no '/' after DESTDIR. Explanation in commence.am
-EXAMPLEDIR=${DESTDIR}$(exec_prefix)/share/hdf5_examples/fortran
-EXAMPLETOPDIR=${DESTDIR}$(exec_prefix)/share/hdf5_examples
+EXAMPLEDIR=$(examplesdir)/fortran
+EXAMPLETOPDIR=$(examplesdir)
# List dependencies for each example. Normally, automake would take
# care of this for us, but if we tell automake about the programs it