summaryrefslogtreecommitdiffstats
path: root/fortran/examples/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2005-07-11 05:07:29 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2005-07-11 05:07:29 (GMT)
commitb802c46622fbcf7d05d2472e0739ca075f5b2e5b (patch)
tree84b583e3fd5c022a8d05dc82cab88b77b8dc1ffd /fortran/examples/Makefile.am
parentb14a4fd95f5c71f31ec344e13a7c398015da41e6 (diff)
downloadhdf5-b802c46622fbcf7d05d2472e0739ca075f5b2e5b.zip
hdf5-b802c46622fbcf7d05d2472e0739ca075f5b2e5b.tar.gz
hdf5-b802c46622fbcf7d05d2472e0739ca075f5b2e5b.tar.bz2
[svn-r11062] Purpose:
bug fix Description: rwdsetexample and attrexample both modify the same file created by dsetexample. Need to serialize all three of them. Platforms tested: Did 50 times of make check in fortran/examples. It used to fail at least once. Now it does not fail.
Diffstat (limited to 'fortran/examples/Makefile.am')
-rw-r--r--fortran/examples/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/fortran/examples/Makefile.am b/fortran/examples/Makefile.am
index 92dabfb..88d1c98 100644
--- a/fortran/examples/Makefile.am
+++ b/fortran/examples/Makefile.am
@@ -51,9 +51,12 @@ CLEANFILES=*.h5 $(EXTRA_PROG)
HDF_FORTRAN=yes
# Some examples depend on files created by other examples.
-rwdsetexample.chkexe_ attrexample.chkexe_: dsetexample.chkexe_
grpdsetexample.chkexe_: grpsexample.chkexe_
refregexample.chkexe_: refobjexample.chkexe_
+# rwdsetexample and attrexample both modify the same file created by
+# dsetexample. Serialize them.
+rwdsetexample.chkexe_: dsetexample.chkexe_
+attrexample.chkexe_: rwdsetexample.chkexe_
# Tell automake how to build examples using h5fc
# Additional dependencies for the examples are listed below