summaryrefslogtreecommitdiffstats
path: root/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAllen Byrne <byrn@hdfgroup.org>2018-09-24 21:32:56 (GMT)
committerAllen Byrne <byrn@hdfgroup.org>2018-09-24 21:32:56 (GMT)
commit2931b5791c3788ed0ba91db0e5f0d823b502dcb4 (patch)
treeeec3e633e8e2f7134a42c50cc031480ba306113c /fortran/src/CMakeLists.txt
parentf59e4a74ef640c2f941552a3f2706d0839eb8a74 (diff)
downloadhdf5-2931b5791c3788ed0ba91db0e5f0d823b502dcb4.zip
hdf5-2931b5791c3788ed0ba91db0e5f0d823b502dcb4.tar.gz
hdf5-2931b5791c3788ed0ba91db0e5f0d823b502dcb4.tar.bz2
HDFFV-10570 add missing files to install
Diffstat (limited to 'fortran/src/CMakeLists.txt')
-rw-r--r--fortran/src/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/fortran/src/CMakeLists.txt b/fortran/src/CMakeLists.txt
index 00035ba..548014a 100644
--- a/fortran/src/CMakeLists.txt
+++ b/fortran/src/CMakeLists.txt
@@ -389,6 +389,13 @@ set (mod_files
${MOD_BUILD_DIR}/h5t_provisional.mod
${MOD_BUILD_DIR}/h5_dble_interface.mod
)
+if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
+ set (mod_files
+ ${mod_files}
+ ${MOD_BUILD_DIR}/HDF5mpio.mod
+ ${MOD_BUILD_DIR}/H5FDmpioff.mod
+ )
+endif ()
install (
FILES
${mod_files}
@@ -429,6 +436,13 @@ if (BUILD_SHARED_LIBS AND NOT SKIP_HDF5_FORTRAN_SHARED)
${MODSH_BUILD_DIR}/h5t_provisional.mod
${MODSH_BUILD_DIR}/h5_dble_interface.mod
)
+ if (H5_HAVE_PARALLEL AND MPI_Fortran_FOUND)
+ set (modsh_files
+ ${modsh_files}
+ ${MODSH_BUILD_DIR}/HDF5mpio.mod
+ ${MODSH_BUILD_DIR}/H5FDmpioff.mod
+ )
+ endif ()
install (
FILES
${modsh_files}