summaryrefslogtreecommitdiffstats
path: root/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2022-10-12 12:38:27 (GMT)
committerGitHub <noreply@github.com>2022-10-12 12:38:27 (GMT)
commitcffaf47c1560dd77a34b9660c8bef527cb4c4e13 (patch)
tree9eb456c08f61e86e451bc23c88e969c0d2f98f06 /fortran/src/CMakeLists.txt
parent64e69d9291e58f56152f91e58b847deb2c172e26 (diff)
downloadhdf5-cffaf47c1560dd77a34b9660c8bef527cb4c4e13.zip
hdf5-cffaf47c1560dd77a34b9660c8bef527cb4c4e13.tar.gz
hdf5-cffaf47c1560dd77a34b9660c8bef527cb4c4e13.tar.bz2
Fix for missing h5dfill_c_long_double in dll (#2155)
* added conditionally include h5dfill_c_long_double in dll
Diffstat (limited to 'fortran/src/CMakeLists.txt')
-rw-r--r--fortran/src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/fortran/src/CMakeLists.txt b/fortran/src/CMakeLists.txt
index b28e8c9..3471041 100644
--- a/fortran/src/CMakeLists.txt
+++ b/fortran/src/CMakeLists.txt
@@ -10,6 +10,9 @@ if (WIN32)
set (H5_NOPAREXP ";")
endif ()
set (H5_F03EXP ";")
+ if (NOT H5_FORTRAN_C_LONG_DOUBLE_IS_UNIQUE)
+ set (H5_FORTRAN_C_LONG_DOUBLE_IS_UNIQUE ";")
+ endif ()
configure_file (${HDF5_F90_SRC_SOURCE_DIR}/hdf5_fortrandll.def.in ${HDF5_F90_SRC_BINARY_DIR}/hdf5_fortrandll.def @ONLY)
endif ()
endif ()