summaryrefslogtreecommitdiffstats
path: root/fortran/src/CMakeLists.txt
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-22 18:50:29 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-04-22 18:50:29 (GMT)
commit0a5ca8ad05ef2d2c8ffeb8205151e391e85b52c4 (patch)
tree8cc4de4fec392878a32e5d0bf182446729eba658 /fortran/src/CMakeLists.txt
parentaad4f74fa93734099be7f10b037bf768eb0d8596 (diff)
downloadhdf5-0a5ca8ad05ef2d2c8ffeb8205151e391e85b52c4.zip
hdf5-0a5ca8ad05ef2d2c8ffeb8205151e391e85b52c4.tar.gz
hdf5-0a5ca8ad05ef2d2c8ffeb8205151e391e85b52c4.tar.bz2
[svn-r26885] Fixed issues with CMake and Fortran on linux.
Diffstat (limited to 'fortran/src/CMakeLists.txt')
-rw-r--r--fortran/src/CMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/fortran/src/CMakeLists.txt b/fortran/src/CMakeLists.txt
index c0c2569..e683725 100644
--- a/fortran/src/CMakeLists.txt
+++ b/fortran/src/CMakeLists.txt
@@ -19,6 +19,16 @@ if (WIN32)
endif (BUILD_SHARED_LIBS)
endif (WIN32)
+# configure for Fortran preprocessor
+
+# Define Parallel variable for passing to H5config_f.inc.cmake
+set (CMAKE_H5_HAVE_PARALLEL 0)
+if (H5_HAVE_PARALLEL)
+ set (CMAKE_H5_HAVE_PARALLEL 1)
+endif (H5_HAVE_PARALLEL)
+
+configure_file (${HDF5_F90_SRC_SOURCE_DIR}/H5config_f.inc.cmake ${CMAKE_BINARY_DIR}/H5config_f.inc @ONLY)
+
#-----------------------------------------------------------------------------
# Setup the Fortran auto-detection utilities
# H5test_kind.F90 used to generate H5fortran_detect.F90
@@ -120,12 +130,6 @@ set (f90CStub_C_SRCS
${HDF5_F90_SRC_SOURCE_DIR}/H5Zf.c
)
-if (H5_HAVE_PARALLEL)
- set (f90CStub_C_SRCS
- ${f90CStub_C_SRCS}
- ${HDF5_F90_SRC_SOURCE_DIR}/H5FDmpiof.c
- )
-endif (H5_HAVE_PARALLEL)
set_source_files_properties (${f90CStub_C_SRCS} PROPERTIES LANGUAGE C)
set (f90CStub_C_HDRS