summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-01 15:40:30 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2008-09-01 15:40:30 (GMT)
commit641df34ddb97999f2c2d0576dc3a3bd1b8165c2a (patch)
tree28ca86e844376320f078216a7264be699a9c8e31 /fortran/src/Makefile.am
parenta3f1ca5e7dc56d0d5cf572f074b77ee1be74c889 (diff)
downloadhdf5-641df34ddb97999f2c2d0576dc3a3bd1b8165c2a.zip
hdf5-641df34ddb97999f2c2d0576dc3a3bd1b8165c2a.tar.gz
hdf5-641df34ddb97999f2c2d0576dc3a3bd1b8165c2a.tar.bz2
[svn-r15573] Description:
Compiles either H5test_kind.f90 or H5test_kind_SIZEOF.f90 depending on the availability of intrinsic Fortran function SIZEOF (indicated by the status of FORTRAN_HAVE_SIZEOF).
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 22f43a7..2f8e841 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -63,7 +63,7 @@ libhdf5_fortran_la_SOURCES=H5fortran_flags.f90 H5f90global.f90 \
H5Tff.f90 H5Zff.f90 \
H5_DBLE_Interface$(F_DBLE).f90 \
H5f90kit.c H5_f.c H5Af.c H5Df.c H5Ef.c H5Ff.c H5Gf.c \
- H5If.c H5Lf.c H5Of.c H5Pf.c H5Rf.c H5Sf.c H5Tf.c H5Zf.c \
+ H5If.c H5Lf.c H5Of.c H5Pf.c H5Rf.c H5Sf.c H5Tf.c H5Zf.c \
$(PARALLEL_COND_SRC)
# h5fc and libhdf5_fortran.settings are generated during configure.
@@ -152,13 +152,20 @@ H5match_types.$(OBJEXT): H5fort_type_defines.h
# files.
H5fortran_detect_SOURCES = H5fortran_detect.f90
-# H5test_kind.f90 generates H5fortran_detect.f90.
+# H5test_kind.f90 generates H5Fortran_detect.f90 depending on if
+# intrinsic function SIZEOF is available.
+
H5fortran_detect.f90: H5test_kind$(EXEEXT)
$(RUNSERIAL) ./H5test_kind$(EXEEXT) > H5fortran_detect.f90
# H5test_kind.f90 is included in the distribution, and Automake knows
# how to compile a fortran program given its sources.
-H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
+
+if FORTRAN_HAVE_SIZEOF
+ H5test_kind_SOURCES = $(srcdir)/H5test_kind_SIZEOF.f90
+else
+ H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
+endif
# Mark this directory as part of the Fortran API
FORTRAN_API=yes
@@ -172,6 +179,7 @@ H5f90global.lo: $(srcdir)/H5f90global.f90 H5fortran_flags.lo H5fortran_type
H5fortran_types.lo: H5fortran_types.f90
H5fortran_detect.lo: H5fortran_detect.f90
H5test_kind.lo: $(srcdir)/H5test_kind.f90
+H5test_kind_SIZEOF.lo: $(srcdir)/H5test_kind_SIZEOF.f90
H5_ff.lo: $(srcdir)/H5_ff.f90 H5f90global.lo
H5Aff.lo: $(srcdir)/H5Aff.f90 H5f90global.lo
H5Dff.lo: $(srcdir)/H5Dff.f90 H5f90global.lo