summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorVailin Choi <vchoi@hdfgroup.org>2013-10-24 21:42:38 (GMT)
committerVailin Choi <vchoi@hdfgroup.org>2013-10-24 21:42:38 (GMT)
commit07a49f439fc44ddec27fd6a25ee0fd52de87ec3c (patch)
tree09a088c34a092f42fdb4502d3ea25a6f16cc892b /fortran/src/Makefile.am
parentbfd1c84d5cdc403c1414395cd49197cd4fc74108 (diff)
downloadhdf5-07a49f439fc44ddec27fd6a25ee0fd52de87ec3c.zip
hdf5-07a49f439fc44ddec27fd6a25ee0fd52de87ec3c.tar.gz
hdf5-07a49f439fc44ddec27fd6a25ee0fd52de87ec3c.tar.bz2
[svn-r24354] Bring revision #24336 from revise_chunks.
h5committested.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 12c38e2..2d597c6 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -79,8 +79,11 @@ libhdf5_fortran_la_SOURCES=H5f90global.f90 \
H5Aff$(F_STATUS).f90 H5Dff$(F_STATUS).f90 H5Eff$(F_STATUS).f90 H5Fff$(F_STATUS).f90 H5Lff$(F_STATUS).f90 \
H5Off$(F_STATUS).f90 H5Pff$(F_STATUS).f90 H5Rff$(F_STATUS).f90 H5Tff$(F_STATUS).f90 $(PARALLEL_COND_SRC)
-# HDF5 Fortran library depends on HDF5 Library.
+# HDF5 Fortran library depends on HDF5 Library. However, only add the dependency
+# if --enable-sharedlib-rpath is yes.
+if LT_ADD_LIBHDF5_DEPENDENCY
libhdf5_fortran_la_LIBADD=$(LIBHDF5)
+endif
# h5fc is generated during configure.
# Remove it only when distclean.