summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2015-05-28 16:53:15 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2015-05-28 16:53:15 (GMT)
commit52e5579fbae41ee79f91eaeb66d452e8b1cc9e09 (patch)
tree0d3fa5ff4f7a4e89b9f469de821377f2fa8482f7 /fortran/src/Makefile.am
parent0560c11c20476a8c99316bd88f1b6924afa057f9 (diff)
downloadhdf5-52e5579fbae41ee79f91eaeb66d452e8b1cc9e09.zip
hdf5-52e5579fbae41ee79f91eaeb66d452e8b1cc9e09.tar.gz
hdf5-52e5579fbae41ee79f91eaeb66d452e8b1cc9e09.tar.bz2
[svn-r27122] removed dependency on generatored fortran source code
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 43a5f3f..d2e06f8 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -60,8 +60,7 @@ DISTCLEANFILES=h5fc
# H5fortran_types.F90 and H5f90i.h are automatically generaed by
# H5match_types, and must be cleaned explicitly. H5fort_type_defines.h
# is generated by H5fortran_detect
-MOSTLYCLEANFILES=H5fortran_types.F90 H5f90i_gen.h H5fort_type_defines.h \
- H5fortran_detect.F90
+MOSTLYCLEANFILES=H5fortran_types.F90 H5f90i_gen.h H5fort_type_defines.h
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules
@@ -138,11 +137,11 @@ H5fortran_types.F90 H5f90i_gen.h: H5match_types$(EXEEXT)
# files.
#H5fortran_detect_SOURCES = H5fortran_detect.F90
-# H5test_kind.F90 generates H5Fortran_detect.F90 depending on if
-# intrinsic function SIZEOF is available.
+# H5test_kind.F90 generates all the APIs that have a KIND type associated
+# with them.
H5_KINDff.F90: H5test_kind$(EXEEXT)
- $(RUNSERIAL) ./H5test_kind$(EXEEXT) > H5fortran_detect.F90
+ $(RUNSERIAL) ./H5test_kind$(EXEEXT)
# H5test_kind.F90 is included in the distribution, and Automake knows
# how to compile a fortran program given its sources.