summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorLarry Knox <lrknox@hdfgroup.org>2010-05-12 20:55:52 (GMT)
committerLarry Knox <lrknox@hdfgroup.org>2010-05-12 20:55:52 (GMT)
commitfa416bde84a8c219fa570660bbf3ec8ab16320e7 (patch)
tree5430f5c54b5d4a458859f7e9e10723c09e4e7673 /fortran/src/Makefile.am
parenteeeb3937624f7db68680e1074b1154adc780d516 (diff)
downloadhdf5-fa416bde84a8c219fa570660bbf3ec8ab16320e7.zip
hdf5-fa416bde84a8c219fa570660bbf3ec8ab16320e7.tar.gz
hdf5-fa416bde84a8c219fa570660bbf3ec8ab16320e7.tar.bz2
[svn-r18779] Add ${DESTDIR} to scripts and Makefiles so that make DESTDIR=<install directory> install, installcheck and uninstall is supported for installing examples, since they are now installed as part of make install. This was necessary for rpmbuilds, but should also be supported otherwise.
Tested: amani, jam, linew with committest, rpmbuild on jam and amani.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index f38e94f..ca938c8 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -100,8 +100,8 @@ install-data-local:
$(CP) $(top_srcdir)/fortran/src/H5f90i.h $(DESTDIR)$(includedir)/.
uninstall-local:
- @if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
- if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
+ @if test -n "$(DESTDIR)$(F9XMODEXT)" -a "X$(DESTDIR)$(F9XMODEXT)" != "Xo"; then \
+ if test -f "$(DESTDIR)$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(DESTDIR)$(includedir)/HDF5.$(F9XMODEXT)"; then \
set -x; $(RM) $(DESTDIR)$(includedir)/*.$(F9XMODEXT); \
fi; \
fi; \