summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorAlbert Cheng <acheng@hdfgroup.org>2008-10-21 04:10:17 (GMT)
committerAlbert Cheng <acheng@hdfgroup.org>2008-10-21 04:10:17 (GMT)
commitfdabaa33302ea79aad089f28fd16ce984d057a61 (patch)
tree11fb9a0d2406f7aa131956f1ab5ebd1e5767490c /fortran/src/Makefile.am
parent7f758bceb0c57871f14eb11e47106a365699aa97 (diff)
downloadhdf5-fdabaa33302ea79aad089f28fd16ce984d057a61.zip
hdf5-fdabaa33302ea79aad089f28fd16ce984d057a61.tar.gz
hdf5-fdabaa33302ea79aad089f28fd16ce984d057a61.tar.bz2
[svn-r15912] Bug fix: #933
The information of libhdf5_fortran.settings are all included in libhdf5.settings now. Remove it from the source. Tested: kagiso with fortran and C++.
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 6da0883..34dc3b9 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -66,9 +66,9 @@ libhdf5_fortran_la_SOURCES=H5fortran_flags.f90 H5f90global.f90 \
H5If.c H5Lf.c H5Of.c H5Pf.c H5Rf.c H5Sf.c H5Tf.c H5Zf.c \
$(PARALLEL_COND_SRC)
-# h5fc and libhdf5_fortran.settings are generated during configure.
-# Remove them only when distclean.
-DISTCLEANFILES=h5fc libhdf5_fortran.settings
+# h5fc is generated during configure.
+# Remove it only when distclean.
+DISTCLEANFILES=h5fc
# H5fortran_types.f90 and H5f90i.h are automatically generaed by
# H5match_types, and must be cleaned explicitly. H5fort_type_defines.h
@@ -104,10 +104,6 @@ uninstall-local:
install-exec-local:
@$(INSTALL) h5fc $(DESTDIR)$(bindir)/$(H5FC_NAME)
-# Install libhdf5_fortran.settings in lib directory
-settingsdir=$(libdir)
-settings_DATA=libhdf5_fortran.settings
-
# Custom rule for installing h5fc, since it will be named h5pfc if hdf5
# is configured for parallel mode
if BUILD_PARALLEL_CONDITIONAL