summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorlrknox <lrknox>2017-01-13 04:20:11 (GMT)
committerlrknox <lrknox>2017-01-13 04:20:11 (GMT)
commit8452976de5d770adcf3892b25c8480042170fccd (patch)
tree4d94cbb8292116af3cf369adf1b47a014210ae17 /fortran/src/Makefile.am
parent089afc48561ba8838d6a515c6b00fc6f7032ca13 (diff)
downloadhdf5-8452976de5d770adcf3892b25c8480042170fccd.zip
hdf5-8452976de5d770adcf3892b25c8480042170fccd.tar.gz
hdf5-8452976de5d770adcf3892b25c8480042170fccd.tar.bz2
tools/test/h5diff/testh5diff.sh.in:
Add code to delete copies of test .h5 files copied from tools/testfiles/vds to tools/test/h5diff/testfiles when running "make check" for an in-source build. tools/test/misc/testh5repart.sh.in: Change the name of the temporary test directory from "testfiles" which is also used for 2 h5mkgrp test files under source control to "testrepart" to avoid deleting source controlled files when running "make check" in the source directory. Fix test scripts that remove source-controlled files during "make check" when run in-source. Fix test scripts that don't remove test files because they add files to test directories but don't remove them if the build directories are the same as the source directory. Fix any test source file or Makefile.am files for tests that leave data files are removed by neither "make check" nor "make distclean".
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index a271666..51775db 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -57,9 +57,9 @@ libhdf5_fortran_la_LIBADD=$(LIBHDF5)
# Remove it only when distclean.
DISTCLEANFILES=h5fc
-# H5fortran_types.F90 and H5f90i.h are automatically generaed by
+# H5fortran_types.F90 and H5f90i.h are automatically generated by
# H5match_types, and must be cleaned explicitly.
-MOSTLYCLEANFILES=H5fortran_types.F90 H5f90i_gen.h
+MOSTLYCLEANFILES=H5fortran_types.F90 H5f90i_gen.h H5_gen.F90
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules