summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorScot Breitenfeld <brtnfld@hdfgroup.org>2010-04-13 19:12:54 (GMT)
committerScot Breitenfeld <brtnfld@hdfgroup.org>2010-04-13 19:12:54 (GMT)
commitc068fe26da17a2a6f857d58857a1db30acc4648a (patch)
tree7d1161dac6ef41ab7c9b0c89c55431f05198d53b /fortran/src/Makefile.am
parenta788a50791cc868ad5a8a5a2338c1e3b18ebbe92 (diff)
downloadhdf5-c068fe26da17a2a6f857d58857a1db30acc4648a.zip
hdf5-c068fe26da17a2a6f857d58857a1db30acc4648a.tar.gz
hdf5-c068fe26da17a2a6f857d58857a1db30acc4648a.tar.bz2
[svn-r18551] Description:
In order to compile stand-alone Fortran wrappers the following files need to be installed via make install: (1) From the source: trunk/fortran/src/H5f90i.h - defines the character type and includes the file H5f90i_gen.h (2) From the compiled source: trunk/fortran/src/H5f90i_gen.h - a generated file at hdf5 compile time relating the C types to the Fortran types for interoperability. Since these C/Fortran types need to match those used in generating h5cc and h5fc commands we include the files H5f90i_gen.h and H5f90i.h in the hdf5/include install directory when Fortran is enabled. the files are installed with the other fortran files in include and also removed when the installation is cleaned. Test: jam
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index d2644a1..f38e94f 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -90,11 +90,14 @@ clean-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
$(RM) *.$(F9XMODEXT); \
fi
+ $(RM) $(DESTDIR)$(includedir)/H5f90i*.h
install-data-local:
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
$(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
fi
+ $(CP) $(top_builddir)/$(subdir)/H5f90i_gen.h $(DESTDIR)$(includedir)/.
+ $(CP) $(top_srcdir)/fortran/src/H5f90i.h $(DESTDIR)$(includedir)/.
uninstall-local:
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
@@ -103,6 +106,7 @@ uninstall-local:
fi; \
fi; \
$(RM) $(DESTDIR)$(bindir)/$(H5FC_NAME)
+ $(RM) $(DESTDIR)$(includedir)/H5f90i*.h
# Also install and uninstall (uninstall-local above) h5fc script
install-exec-local: