summaryrefslogtreecommitdiffstats
path: root/fortran/src/Makefile.am
diff options
context:
space:
mode:
authorJames Laird <jlaird@hdfgroup.org>2005-11-18 20:31:53 (GMT)
committerJames Laird <jlaird@hdfgroup.org>2005-11-18 20:31:53 (GMT)
commit0f870b0f479c8f561def96e689fc8835b70de156 (patch)
tree2d15f750a4b6d5f9e2ad7c7be76c94c387ddab23 /fortran/src/Makefile.am
parent0426d8d7e17a69ce3e6d870ad981d366c466c42d (diff)
downloadhdf5-0f870b0f479c8f561def96e689fc8835b70de156.zip
hdf5-0f870b0f479c8f561def96e689fc8835b70de156.tar.gz
hdf5-0f870b0f479c8f561def96e689fc8835b70de156.tar.bz2
[svn-r11741] Purpose:
Bug fix Description: Fortran type generation was broken in two ways. Fixed both. Solution: Firstly, there were a couple of path problems. Fixed a typo and specified the full path of a file. Secondly, the dependencies weren't right when building with HDF5-specific commands (make lib, make check-s, etc.). Tweaked dependencies to fix the problem. Platforms tested: mir, modi4, sleipnir
Diffstat (limited to 'fortran/src/Makefile.am')
-rw-r--r--fortran/src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/fortran/src/Makefile.am b/fortran/src/Makefile.am
index 266186f..52854a3 100644
--- a/fortran/src/Makefile.am
+++ b/fortran/src/Makefile.am
@@ -22,7 +22,7 @@ include $(top_srcdir)/config/commence.am
# Include src directory in both Fortran and C flags (C compiler is used
# for linking).
INCLUDES = -I$(top_srcdir)/src
-AM_FCFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/src/fortran
+AM_FCFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/fortran/src
AM_FCLIBS=$(LIBHDF5)
@@ -144,7 +144,7 @@ H5fortran_detect.f90: H5test_kind$(EXEEXT)
# H5test_kind.f90 is included in the distribution, and Automake knows
# how to compile a fortran program given its sources.
-H5test_kind_SOURCES = H5test_kind.f90
+H5test_kind_SOURCES = $(srcdir)/H5test_kind.f90
# Mark this directory as part of the Fortran API
HDF_FORTRAN=yes